编译TensorFlow支持CUDA10.1

作者:hws000(hws.000#163.com)
声明:版权所有,转载请联系作者。
出处:https://blog.simbot.net/index.php/2019/09/27/build-tensorflow-with-cuda10-1-support/

        最新的Nvidia驱动已经更新到426了,对应的是CUDA10.1,而 TensorFlow的官方版本只支持CUDA10.0 ,想用最新的驱动貌似只能自己编译了。

      其实编译TensorFlow很简单,按照官方的教程,在configure时显示指定CUDA版本就可以。

        TF_CUDA_VERSION=10.1 TF_CUDNN_VERSION=7 python ./configure.py

        否则build_info.py里的CUDA版本会出现错误,表现如下:

        cudart_dll_name = 'cudart64_.dll'
        cudnn_dll_name = 'cudnn64_.dll'

发表评论

电子邮件地址不会被公开。 必填项已用*标注